Topic: Installing and Configuring TFTP Server on UbuntuError:Begin trying netboot from 172.16.6.223:/ … [19.387543] FS-Cache: netfs nfs registered for cachingBegin trying nfsmount -o nolock -o ro 172.16.6.223:/ /cdrom mount call failed – server replied : permission deniedNote: I followed ur documentsudo chmod -Rfv 777 /netbootIn export/netboot/nfs *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,no_subtree_check)

Question

I did nfs mount and I gave full permission of netboot folder

solved 0
happyvinod 2 weeks 1 Answer 36 views

Answer ( 1 )

  1. Hi happyvinod,

    Try to set SELinux to permissive mode and see if it works.

    $ sudo setenforce 0

     

    If it does work after setting SELinux to permissive mode, then the problem is SELinux. You will have to add the required SELinux permissions to the nfs directory for it to work. If you don’t want to configure SELinux and it’s not a production server, then you may keep it simple and disable SELinux.

     

    If it does not work after setting SELinux to permissive mode, then there might be some other problem.

     

    Let me know what happens once you set SELinux to permissive mode.

     

    Good luck.

    Shovon

    Best answer

Leave an answer